[toolchain] fix kernel-headers build for uml
[openwrt/svn-archive/archive.git] / toolchain / kernel-headers / Makefile
index 63687cbf50254018cfc8b17a1acae9c4388daa15..47e7b245b1e72f66e356bc83c06ec81c0dda3a21 100644 (file)
@@ -26,7 +26,7 @@ include $(INCLUDE_DIR)/toolchain-build.mk
 include $(INCLUDE_DIR)/kernel-defaults.mk
 
 ifeq ($(strip $(BOARD)),uml)
-  LINUX_KARCH:=$(ARCH)
+  LINUX_KARCH:=$(subst x86_64,x86,$(subst i386,x86,$(ARCH)))
 endif
 
 ifeq ($(strip $(call CompareKernelPatchVer,$(KERNEL_PATCHVER),ge,2.6.18)),1)