gcc: add llvm-gcc and llvm from trunk (does not successfully compile a target yet...
[openwrt/svn-archive/archive.git] / toolchain / llvm / patches / 100-darwin_arch_auto.patch
diff --git a/toolchain/llvm/patches/100-darwin_arch_auto.patch b/toolchain/llvm/patches/100-darwin_arch_auto.patch
new file mode 100644 (file)
index 0000000..a48e131
--- /dev/null
@@ -0,0 +1,19 @@
+--- a/Makefile.rules
++++ b/Makefile.rules
+@@ -618,16 +618,6 @@ ifdef UNIVERSAL
+   # Building universal cannot compute dependencies automatically.
+   DISABLE_AUTO_DEPENDENCIES=1
+-else
+-  ifeq ($(TARGET_OS),Darwin)
+-    ifeq ($(ARCH),x86_64)
+-      TargetCommonOpts = -m64
+-    else
+-      ifeq ($(ARCH),x86)
+-        TargetCommonOpts = -m32
+-      endif
+-    endif
+-  endif
+ endif
+ ifeq ($(HOST_OS),SunOS)