gcc: add llvm-gcc and llvm from trunk (does not successfully compile a target yet...
[openwrt/svn-archive/archive.git] / toolchain / llvm / patches / 110-darwin_version_detect.patch
diff --git a/toolchain/llvm/patches/110-darwin_version_detect.patch b/toolchain/llvm/patches/110-darwin_version_detect.patch
new file mode 100644 (file)
index 0000000..7fd62f9
--- /dev/null
@@ -0,0 +1,16 @@
+--- a/Makefile.rules
++++ b/Makefile.rules
+@@ -506,11 +506,13 @@ endif
+ #--------------------------------------------------------------------
+ ifeq ($(HOST_OS),Darwin)
++  ifndef DARWIN_VERSION
+   DARWIN_VERSION := `sw_vers -productVersion`
+   # Strip a number like 10.4.7 to 10.4
+   DARWIN_VERSION := $(shell echo $(DARWIN_VERSION)| sed -E 's/(10.[0-9]).*/\1/')
+   # Get "4" out of 10.4 for later pieces in the makefile.
+   DARWIN_MAJVERS := $(shell echo $(DARWIN_VERSION)| sed -E 's/10.([0-9]).*/\1/')
++  endif
+   SharedLinkOptions=-Wl,-flat_namespace -Wl,-undefined -Wl,suppress \
+                     -dynamiclib