uClibc: update 0.9.32 to latest git
[openwrt/svn-archive/archive.git] / toolchain / uClibc / patches-0.9.32 / 600-ubicom32-uClibc.patch
index 50bed1a474fdb334bc27af2f6b6a72ba054fb71a..234e1672d774bd97c5e18d2c8da362a397399f53 100644 (file)
@@ -1,6 +1,6 @@
 --- a/Rules.mak
 +++ b/Rules.mak
-@@ -477,6 +477,17 @@ ifeq ($(TARGET_ARCH),microblaze)
+@@ -481,6 +481,17 @@
        SYMBOL_PREFIX=_
  endif
  
@@ -20,7 +20,7 @@
  endif
 --- a/extra/Configs/Config.in
 +++ b/extra/Configs/Config.in
-@@ -102,6 +102,9 @@ config TARGET_sh64
+@@ -102,6 +102,9 @@
  config TARGET_sparc
        bool "sparc"
  
@@ -30,7 +30,7 @@
  config TARGET_v850
        bool "v850 (BROKEN)"
  
-@@ -203,6 +206,10 @@ if TARGET_sparc
+@@ -203,6 +206,10 @@
  source "extra/Configs/Config.sparc"
  endif
  
@@ -43,7 +43,7 @@
  endif
 --- a/extra/Configs/Config.in.arch
 +++ b/extra/Configs/Config.in.arch
-@@ -149,7 +149,7 @@ config UCLIBC_HAS_SOFT_FLOAT
+@@ -149,7 +149,7 @@
  config DO_C99_MATH
        bool "Enable full C99 math library support"
        depends on UCLIBC_HAS_FLOATS
 +      string
 --- a/include/elf.h
 +++ b/include/elf.h
-@@ -337,6 +337,8 @@ typedef struct
+@@ -337,6 +337,8 @@
  
  #define EM_XSTORMY16          0xad45
  
  /* FRV magic number - no EABI available??.  */
  #define EM_CYGNUS_FRV 0x5441
  
-@@ -3063,6 +3065,55 @@ typedef Elf32_Addr Elf32_Conflict;
+@@ -3063,6 +3065,55 @@
  /* Keep this the last entry.  */
  #define R_XTENSA_NUM          50
  
  #endif
 --- a/include/features.h
 +++ b/include/features.h
-@@ -445,4 +445,10 @@ uClibc was built without large file supp
+@@ -445,4 +445,10 @@
  # include <libc-internal.h>
  #endif
  
  #endif        /* features.h  */
 --- a/ldso/ldso/dl-startup.c
 +++ b/ldso/ldso/dl-startup.c
-@@ -164,10 +164,13 @@ DL_START(unsigned long args)
+@@ -164,10 +164,13 @@
                aux_dat += 2;
        }
  
  
 --- a/ldso/ldso/ldso.c
 +++ b/ldso/ldso/ldso.c
-@@ -325,10 +325,12 @@ void _dl_get_ready_to_run(struct elf_res
+@@ -327,10 +327,12 @@
                _dl_progname = argv[0];
        }
  
 +      .size   _dl_ubicom32_resolve_pending, . - _dl_ubicom32_resolve_pending
 --- a/libc/misc/Makefile.in
 +++ b/libc/misc/Makefile.in
-@@ -12,7 +12,9 @@ include $(top_srcdir)libc/misc/assert/Ma
+@@ -12,7 +12,9 @@
  include $(top_srcdir)libc/misc/ctype/Makefile.in
  include $(top_srcdir)libc/misc/dirent/Makefile.in
  include $(top_srcdir)libc/misc/error/Makefile.in
 +      .set __GI_vfork,vfork
 --- a/libpthread/linuxthreads.old/pthread.c
 +++ b/libpthread/linuxthreads.old/pthread.c
-@@ -393,6 +393,10 @@ void __pthread_initialize_minimal(void)
+@@ -393,6 +393,10 @@
  #endif
  
      __libc_multiple_threads_ptr = __libc_pthread_init (ptr_pthread_functions);
  }
  
  
-@@ -461,8 +465,11 @@ static void pthread_initialize(void)
+@@ -461,8 +465,11 @@
     * __pthread_initial_thread_bos at address 0. These bounds are refined as we
     * malloc other stack frames such that they don't overlap. -StS
     */