Device Tree Compiler require more recent bison ...
[openwrt/svn-archive/archive.git] / tools / bison / Makefile
diff --git a/tools/bison/Makefile b/tools/bison/Makefile
new file mode 100644 (file)
index 0000000..2b85612
--- /dev/null
@@ -0,0 +1,33 @@
+# 
+# Copyright (C) 2008 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=bison
+PKG_VERSION:=2.3
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=ftp://ftp.gnu.org/gnu/$(PKG_NAME)
+PKG_MD5SUM:=22327efdd5080e2b1acb6e560a04b43a
+PKG_CAT:=zcat
+
+include $(INCLUDE_DIR)/host-build.mk
+
+define Build/Compile
+       $(MAKE) -C $(PKG_BUILD_DIR)
+endef
+
+define Build/Install
+       $(MAKE) -C $(PKG_BUILD_DIR) install
+endef
+
+define Build/Clean
+       $(MAKE) -C $(PKG_BUILD_DIR) uninstall
+       $(MAKE) -C $(PKG_BUILD_DIR) clean
+       $(call Build/Clean/Default)
+endef
+
+$(eval $(call HostBuild))