[tools] add mktools and dosfstools which are needed for the raspberry pi
[openwrt/svn-archive/archive.git] / tools / dosfstools / Makefile
diff --git a/tools/dosfstools/Makefile b/tools/dosfstools/Makefile
new file mode 100644 (file)
index 0000000..88ac057
--- /dev/null
@@ -0,0 +1,30 @@
+# 
+# Copyright (C) 2012 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=dosfstools
+PKG_VERSION:=3.0.7
+PKG_SOURCE:=$(PKG_NAME)_$(PKG_VERSION).orig.tar.gz
+PKG_SOURCE_URL:=http://dosfstools.sourcearchive.com/downloads/3.0.7/
+PKG_MD5SUM:=5d4d97c79e8dae60bb08c2fba36c94d6
+PKG_CAT:=zcat
+
+include $(INCLUDE_DIR)/host-build.mk
+
+define Host/Compile
+       $(MAKE) -C $(HOST_BUILD_DIR) SHELL="$(BASH)"
+endef
+
+define Host/Install
+       $(INSTALL_BIN) $(HOST_BUILD_DIR)/mkdosfs $(STAGING_DIR_HOST)/bin/
+endef
+
+define Host/Clean
+       rm -f $(STAGING_DIR_HOST)/bin/mkdosfs
+endef
+
+$(eval $(call HostBuild))