[tools] flock: link statically
[openwrt/svn-archive/archive.git] / tools / flock / Makefile
index 64a8655b831c8219e846aa2a0e59971648dea642..ead98e7329073e746cc9b6956513c4d6258fcaa1 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006-2008 OpenWrt.org
+# Copyright (C) 2006-2012 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -12,7 +12,7 @@ include $(INCLUDE_DIR)/host-build.mk
 
 define Host/Compile
        mkdir -p $(HOST_BUILD_DIR)
-       $(HOSTCC) $(HOST_CFLAGS) -o $(HOST_BUILD_DIR)/flock src/flock.c
+       $(HOSTCC) $(HOST_CFLAGS) -static -o $(HOST_BUILD_DIR)/flock src/flock.c
 endef
 
 define Host/Install