build system refactoring in preparation for allowing packages to do host-build steps
[openwrt/svn-archive/archive.git] / tools / mpfr / Makefile
index 58a15eb273a6d5e0e52e422b01c305a089eac874..5abb2a2c792ea587c3624212930daf1fea731d1a 100644 (file)
@@ -15,8 +15,8 @@ PKG_MD5SUM:=527147c097874340cb9cee0579dacf3b
 
 include $(INCLUDE_DIR)/host-build.mk
 
-define Build/Configure
-       (cd $(PKG_BUILD_DIR); \
+define Host/Configure
+       (cd $(HOST_BUILD_DIR); \
        ./configure \
          --prefix=$(STAGING_DIR_HOST) \
          --build=$(GNU_HOST_NAME) \
@@ -26,16 +26,16 @@ define Build/Configure
        );
 endef
 
-define Build/Compile
-       make -C $(PKG_BUILD_DIR) all
+define Host/Compile
+       make -C $(HOST_BUILD_DIR) all
 endef
 
-define Build/Install
-       make -C $(PKG_BUILD_DIR) install
+define Host/Install
+       make -C $(HOST_BUILD_DIR) install
 endef
 
-define Build/Clean
-       rm -rf $(PKG_BUILD_DIR)
+define Host/Clean
+       rm -rf $(HOST_BUILD_DIR)
 endef
 
 $(eval $(call HostBuild))