[tools/wrt350nv2-builder] Update to v2.1
[openwrt/svn-archive/archive.git] / tools / wrt350nv2-builder / Makefile
index 648dd84db9c75d945ace54a90bccf378a7c1e300..b07f511f0765c191e14f3ee1d66c812cbb993a5f 100644 (file)
@@ -1,5 +1,5 @@
 # 
-# Copyright (C) 2006-2009 OpenWrt.org
+# Copyright (C) 2006-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,7 +8,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=wrt350nv2-builder
-PKG_VERSION:=2.0
+PKG_VERSION:=2.1
 
 HOST_BUILD_DIR:=$(BUILD_DIR_HOST)/${PKG_NAME}-$(PKG_VERSION)
 
@@ -24,10 +24,16 @@ endef
 define Host/Install
        $(INSTALL_DIR) $(STAGING_DIR_HOST)/bin
        $(INSTALL_BIN) $(HOST_BUILD_DIR)/wrt350nv2-builder $(STAGING_DIR_HOST)/bin/
+# optionally the builder can add a u-boot binary to create a complete webupgrade image, but this is not mandatory
+# u-boot images from stock firmware are available at ftp://ftp.maddes.net/openwrt/kamikaze/orion/stock/binaries/
+       [ ! -f "files/u-boot.bin" ] || ( \
+               $(INSTALL_DIR) $(STAGING_DIR_HOST)/share/wrt350nv2-builder; \
+               $(CP) files/u-boot.bin $(STAGING_DIR_HOST)/share/wrt350nv2-builder/; )
 endef
 
 define Host/Clean
        rm -f $(STAGING_DIR_HOST)/bin/wrt350nv2-builder
+       rm -f $(STAGING_DIR_HOST)/share/wrt350nv2-builder
 endef
 
 $(eval $(call HostBuild))