fstools: allow to compress the filesystem
[project/fstools.git] / CMakeLists.txt
index 9e855bda27699f26e0831565a3813daa55636132..4844c0381840e048582e95ba24b5daad15a53ef9 100644 (file)
@@ -52,6 +52,10 @@ INSTALL(FILES libubi/libubi-tiny.h libubi/libubi.h libubi/ubi-media.h
        DESTINATION include
 )
 
+IF(DEFINED CMAKE_OVL_MOUNT_COMPRESS_ZLIB)
+       ADD_DEFINITIONS(-DOVL_MOUNT_COMPRESS_ZLIB)
+ENDIF(DEFINED CMAKE_OVL_MOUNT_COMPRESS_ZLIB)
+
 ADD_EXECUTABLE(mount_root mount_root.c)
 TARGET_LINK_LIBRARIES(mount_root fstools)
 INSTALL(TARGETS mount_root RUNTIME DESTINATION sbin)