build: add variable to restrict po language and use it for the core i18n packages
[project/luci.git] / build / module.mk
index 6aeb9ba56eaa909f4e7b126fe09a1acdcfa0089d..70d54dc8528313d689d8dbd8dcf2215829e0e071 100644 (file)
@@ -26,7 +26,7 @@ luasource:
        for i in $$(find dist -name .svn -or -name .gitignore); do rm -rf $$i || true; done
   ifneq ($(PO),)
        for file in $(PO); do \
-         cp $(HOST)/lua-po/$$file.*.lua dist$(LUCI_MODULEDIR)/i18n/; \
+         cp $(HOST)/lua-po/$$file.$(if $(PO_LANG),$(PO_LANG),*).lua dist$(LUCI_MODULEDIR)/i18n/; \
        done
   endif