Avoid unnecessary compiling
[project/luci.git] / contrib / uci / Makefile
index 04aa38b3ac9561bf06c41d666eff5c53515fa369..b39278789b11beb266079b6f8baedc3e0c9f7a0f 100644 (file)
@@ -20,12 +20,10 @@ include ../../build/module.mk
 $(UCI_FILE):
        wget -O $@ "$(UCI_URL)" || rm -f $@
 
-$(UCI_PATCHDIR)/series:
-       (cd $(UCI_PATCHDIR); ls *.patch | sort > series)
-
-$(UCI_DIR)/.prepared: $(UCI_PATCHDIR)/series $(UCI_FILE)
+$(UCI_DIR)/.prepared: $(UCI_FILE)
        rm -rf $(UCI_DIR)
        tar xvfz $(UCI_FILE)
+       (cd $(UCI_PATCHDIR); ls *.patch | sort > series) || true
        [ -f "$(UCI_PATCHDIR)/series" ] && while read patch; do \
                patch -d $(UCI_DIR) -p1 < $(UCI_PATCHDIR)/$$patch; \
        done < $(UCI_PATCHDIR)/series || true