fix bogus quilt patch apply errors
[project/luci.git] / libs / sgi-webuci / Makefile
index c679710b67c60e90a2921da589a30e94a69594f2..c7f70eb5c8a6063fd9524e3ed0bc9968053c7e27 100644 (file)
@@ -24,7 +24,7 @@ $(BOA_DIR)/.prepared: $(BOA_FILE)
 $(BOA_DIR)/.patched: $(BOA_DIR)/.prepared $(BOA_PATCHDIR)/series
        (cd $(BOA_DIR); \
                if [ -x "$$(which quilt 2>/dev/null)" ]; then \
-                       quilt push -a; \
+                       [ "$$(quilt top 2>/dev/null)" = "$$(tail -n1 patches/series)" ] || quilt push -a; \
                else \
                        cat patches/*.patch | patch -p1; \
                fi; \