jail: add option to provide /dev/console to containers
[project/procd.git] / CMakeLists.txt
index cff47cfa38c4db46e35a8189ffeb62200d5f7475..3eb79f9ea08899e49d4098eeeadbc08dcb429b32 100644 (file)
@@ -110,6 +110,12 @@ INSTALL(TARGETS ujail
        RUNTIME DESTINATION ${CMAKE_INSTALL_SBINDIR}
 )
 ADD_DEPENDENCIES(ujail capabilities-names-h)
+
+ADD_EXECUTABLE(ujail-console jail/console.c)
+TARGET_LINK_LIBRARIES(ujail-console ${ubox} ${ubus} ${blobmsg_json})
+INSTALL(TARGETS ujail-console
+       RUNTIME DESTINATION ${CMAKE_INSTALL_SBINDIR}
+)
 endif()
 
 IF(UTRACE_SUPPORT)