cmake: Fix find_library for ubusd and examples/server
[project/ubus.git] / examples / CMakeLists.txt
index 006dac42a27ca291174f9f98eaf3e5c7195b0b28..81f9997529505235a363bfed9094c01963b92e1c 100644 (file)
@@ -5,7 +5,7 @@ INCLUDE_DIRECTORIES(${CMAKE_CURRENT_SOURCE_DIR}/..)
 
 IF (BUILD_EXAMPLES)
        ADD_EXECUTABLE(server server.c count.c)
-       TARGET_LINK_LIBRARIES(server ubus ${ubox_library} ${blob_library})
+       TARGET_LINK_LIBRARIES(server ubus ${ubox_library} ${blob_library} ${json})
 
        ADD_EXECUTABLE(client client.c count.c)
        TARGET_LINK_LIBRARIES(client ubus ${ubox_library})