cmake: Add ubox, blobmsg_json libraries and include dirs lookup
authorPetr Štetiar <ynezz@true.cz>
Sat, 5 Mar 2016 13:59:33 +0000 (14:59 +0100)
committerFelix Fietkau <nbd@openwrt.org>
Mon, 7 Mar 2016 08:38:04 +0000 (09:38 +0100)
Otherwise cmake uses files from system which sometimes isn't wanted, ie.
for testing.

Signed-off-by: Petr Å tetiar <ynezz@true.cz>
CMakeLists.txt
examples/CMakeLists.txt

index b1fdd5b7a5dd4c54e15bb5278ed058ac2f840ff2..e21a04698913fe63b06980380ac2aacd39189e6a 100644 (file)
@@ -19,16 +19,27 @@ IF(APPLE)
   LINK_DIRECTORIES(/opt/local/lib)
 ENDIF()
 
+IF(BUILD_STATIC)
+  FIND_LIBRARY(ubox_library NAMES ubox.a)
+  FIND_LIBRARY(blob_library NAMES blobmsg_json.a)
+ELSE(BUILD_STATIC)
+  FIND_LIBRARY(ubox_library NAMES ubox)
+  FIND_LIBRARY(blob_library NAMES blobmsg_json)
+ENDIF(BUILD_STATIC)
+
+FIND_PATH(ubox_include_dir libubox/usock.h)
+INCLUDE_DIRECTORIES(${ubox_include_dir})
+
 ADD_LIBRARY(ubus SHARED libubus.c libubus-io.c libubus-obj.c libubus-sub.c libubus-req.c libubus-acl.c)
-TARGET_LINK_LIBRARIES(ubus ubox)
+TARGET_LINK_LIBRARIES(ubus ${ubox_library})
 
 ADD_EXECUTABLE(ubusd ubusd.c ubusd_id.c ubusd_obj.c ubusd_proto.c ubusd_event.c ubusd_acl.c ubusd_monitor.c)
-TARGET_LINK_LIBRARIES(ubusd ubox blobmsg_json ${json})
+TARGET_LINK_LIBRARIES(ubusd ${ubox_library} ${blob_library} ${json})
 
 find_library(json NAMES json-c json)
 ADD_EXECUTABLE(cli cli.c)
 SET_TARGET_PROPERTIES(cli PROPERTIES OUTPUT_NAME ubus)
-TARGET_LINK_LIBRARIES(cli ubus ubox blobmsg_json ${json})
+TARGET_LINK_LIBRARIES(cli ubus ${ubox_library} ${blob_library} ${json})
 
 ADD_SUBDIRECTORY(lua)
 ADD_SUBDIRECTORY(examples)
index 0279f6e66b50cc4bc0207bf9dfc6f19b83548190..006dac42a27ca291174f9f98eaf3e5c7195b0b28 100644 (file)
@@ -5,8 +5,8 @@ INCLUDE_DIRECTORIES(${CMAKE_CURRENT_SOURCE_DIR}/..)
 
 IF (BUILD_EXAMPLES)
        ADD_EXECUTABLE(server server.c count.c)
-       TARGET_LINK_LIBRARIES(server ubus ubox blobmsg_json)
+       TARGET_LINK_LIBRARIES(server ubus ${ubox_library} ${blob_library})
 
        ADD_EXECUTABLE(client client.c count.c)
-       TARGET_LINK_LIBRARIES(client ubus ubox)
+       TARGET_LINK_LIBRARIES(client ubus ${ubox_library})
 ENDIF()