x86: generate EFI platform bootable images
[openwrt/staging/chunkeey.git] / config / Config-images.in
index 5c2e79e41e4f8940c83b1ceec211fe2c32ed1f40..4c54ac9399f68ccec1d93db45030389fd360bc00 100644 (file)
@@ -14,7 +14,10 @@ menu "Target Images"
 
                choice
                        prompt "Compression"
 
                choice
                        prompt "Compression"
+                       default TARGET_INITRAMFS_COMPRESSION_LZMA if TARGET_apm821xx
                        default TARGET_INITRAMFS_COMPRESSION_LZMA if TARGET_ar71xx
                        default TARGET_INITRAMFS_COMPRESSION_LZMA if TARGET_ar71xx
+                       default TARGET_INITRAMFS_COMPRESSION_LZMA if TARGET_lantiq
+                       default TARGET_INITRAMFS_COMPRESSION_LZMA if TARGET_mpc85xx
                        default TARGET_INITRAMFS_COMPRESSION_LZMA if TARGET_ramips
                        default TARGET_INITRAMFS_COMPRESSION_NONE
                        depends on TARGET_ROOTFS_INITRAMFS
                        default TARGET_INITRAMFS_COMPRESSION_LZMA if TARGET_ramips
                        default TARGET_INITRAMFS_COMPRESSION_NONE
                        depends on TARGET_ROOTFS_INITRAMFS
@@ -50,6 +53,13 @@ menu "Target Images"
                        help
                          Kernel uses specified external cpio as INITRAMFS_SOURCE.
 
                        help
                          Kernel uses specified external cpio as INITRAMFS_SOURCE.
 
+               config TARGET_INITRAMFS_FORCE
+                        bool "Force"
+                        depends on TARGET_ROOTFS_INITRAMFS
+                        default n
+                        help
+                          Ignore the initramfs passed by the bootloader.
+
        comment "Root filesystem archives"
 
        config TARGET_ROOTFS_CPIOGZ
        comment "Root filesystem archives"
 
        config TARGET_ROOTFS_CPIOGZ
@@ -72,13 +82,6 @@ menu "Target Images"
                help
                  Build an ext4 root filesystem.
 
                help
                  Build an ext4 root filesystem.
 
-               config TARGET_EXT4_MAXINODE
-                       int "Maximum number of inodes in root filesystem"
-                       depends on TARGET_ROOTFS_EXT4FS
-                       default 6000
-                       help
-                         Select the maximum number of inodes in the root filesystem.
-
                config TARGET_EXT4_RESERVED_PCT
                        int "Percentage of reserved blocks in root filesystem"
                        depends on TARGET_ROOTFS_EXT4FS
                config TARGET_EXT4_RESERVED_PCT
                        int "Percentage of reserved blocks in root filesystem"
                        depends on TARGET_ROOTFS_EXT4FS
@@ -117,16 +120,9 @@ menu "Target Images"
                        help
                          Create an ext4 filesystem with a journal.
 
                        help
                          Create an ext4 filesystem with a journal.
 
-       config TARGET_ROOTFS_ISO
-               bool "iso"
-               default n
-               depends on TARGET_x86_generic
-               help
-                 Create a bootable ISO image.
-
        config TARGET_ROOTFS_JFFS2
                bool "jffs2"
        config TARGET_ROOTFS_JFFS2
                bool "jffs2"
-               default y if USES_JFFS2
+               depends on USES_JFFS2
                help
                  Build a JFFS2 root filesystem.
 
                help
                  Build a JFFS2 root filesystem.
 
@@ -147,6 +143,7 @@ menu "Target Images"
                        int "Block size (in KiB)"
                        depends on TARGET_ROOTFS_SQUASHFS
                        default 64 if LOW_MEMORY_FOOTPRINT
                        int "Block size (in KiB)"
                        depends on TARGET_ROOTFS_SQUASHFS
                        default 64 if LOW_MEMORY_FOOTPRINT
+                       default 1024 if (SMALL_FLASH && !LOW_MEMORY_FOOTPRINT)
                        default 256
 
        menuconfig TARGET_ROOTFS_UBIFS
                        default 256
 
        menuconfig TARGET_ROOTFS_UBIFS
@@ -186,66 +183,82 @@ menu "Target Images"
 
        config GRUB_IMAGES
                bool "Build GRUB images (Linux x86 or x86_64 host only)"
 
        config GRUB_IMAGES
                bool "Build GRUB images (Linux x86 or x86_64 host only)"
-               depends on TARGET_x86_64 || (TARGET_x86 && !(TARGET_x86_olpc || TARGET_x86_rdc))
-               depends on TARGET_ROOTFS_EXT4FS || TARGET_ROOTFS_ISO || TARGET_ROOTFS_JFFS2 || TARGET_ROOTFS_SQUASHFS
+               depends on TARGET_x86
+               depends on TARGET_ROOTFS_EXT4FS || TARGET_ROOTFS_JFFS2 || TARGET_ROOTFS_SQUASHFS
+               select PACKAGE_grub2
+               default y
+
+       config GRUB_EFI_IMAGES
+               bool "Build GRUB EFI images (Linux x86 or x86_64 host only)"
+               depends on TARGET_x86
+               depends on TARGET_ROOTFS_EXT4FS || TARGET_ROOTFS_JFFS2 || TARGET_ROOTFS_SQUASHFS
                select PACKAGE_grub2
                select PACKAGE_grub2
+               select PACKAGE_grub2-efi
+               select PACKAGE_kmod-fs-vfat
                default y
 
        config GRUB_CONSOLE
                bool "Use Console Terminal (in addition to Serial)"
                default y
 
        config GRUB_CONSOLE
                bool "Use Console Terminal (in addition to Serial)"
-               depends on GRUB_IMAGES
-               default n if (TARGET_x86_generic_Soekris45xx || TARGET_x86_generic_Soekris48xx || TARGET_x86_net5501 || TARGET_x86_geos || TARGET_x86_alix2)
+               depends on GRUB_IMAGES || GRUB_EFI_IMAGES
                default y
 
        config GRUB_SERIAL
                string "Serial port device"
                default y
 
        config GRUB_SERIAL
                string "Serial port device"
-               depends on GRUB_IMAGES
-               default "hvc0" if TARGET_x86_xen_domu
-               default "ttyS0" if ! TARGET_x86_xen_domu
+               depends on GRUB_IMAGES || GRUB_EFI_IMAGES
+               default "ttyS0"
 
        config GRUB_BAUDRATE
                int "Serial port baud rate"
 
        config GRUB_BAUDRATE
                int "Serial port baud rate"
-               depends on GRUB_IMAGES
-               default 19200 if TARGET_x86_generic_Soekris45xx || TARGET_x86_generic_Soekris48xx || TARGET_x86_net5501
-               default 38400 if TARGET_x86_alix2
-               default 115200 if TARGET_x86_geos || TARGET_x86_kvm_guest
-               default 38400
+               depends on GRUB_IMAGES || GRUB_EFI_IMAGES
+               default 38400 if TARGET_x86_generic
+               default 115200
+
+       config GRUB_FLOWCONTROL
+               bool "Use RTE/CTS on serial console"
+               depends on GRUB_SERIAL != ""
+               default n
 
        config GRUB_BOOTOPTS
                string "Extra kernel boot options"
 
        config GRUB_BOOTOPTS
                string "Extra kernel boot options"
-               depends on GRUB_IMAGES
-               default "xencons=hvc" if TARGET_x86_xen_domu
+               depends on GRUB_IMAGES || GRUB_EFI_IMAGES
                help
                  If you don't know, just leave it blank.
 
        config GRUB_TIMEOUT
                string "Seconds to wait before booting the default entry"
                help
                  If you don't know, just leave it blank.
 
        config GRUB_TIMEOUT
                string "Seconds to wait before booting the default entry"
-               depends on GRUB_IMAGES
+               depends on GRUB_IMAGES || GRUB_EFI_IMAGES
                default "5"
                help
                  If you don't know, 5 seconds is a reasonable default.
 
                default "5"
                help
                  If you don't know, 5 seconds is a reasonable default.
 
+       config GRUB_TITLE
+               string "Title for the menu entry in GRUB"
+               depends on GRUB_IMAGES || GRUB_EFI_IMAGES
+               default "OpenWrt"
+               help
+                 This is the title of the GRUB menu entry.
+                 If unspecified, it defaults to OpenWrt.
+
+       config ISO_IMAGES
+               bool "Build LiveCD image (ISO)"
+               depends on TARGET_x86
+               depends on GRUB_IMAGES || GRUB_EFI_IMAGES
+
        config VDI_IMAGES
                bool "Build VirtualBox image files (VDI)"
        config VDI_IMAGES
                bool "Build VirtualBox image files (VDI)"
-               depends on TARGET_x86 || TARGET_x86_64
-               select GRUB_IMAGES
-               select TARGET_IMAGES_PAD
+               depends on TARGET_x86
+               depends on GRUB_IMAGES || GRUB_EFI_IMAGES
                select PACKAGE_kmod-e1000
 
        config VMDK_IMAGES
                bool "Build VMware image files (VMDK)"
                select PACKAGE_kmod-e1000
 
        config VMDK_IMAGES
                bool "Build VMware image files (VMDK)"
-               depends on TARGET_x86 || TARGET_x86_64
-               select GRUB_IMAGES
-               select TARGET_IMAGES_PAD
+               depends on TARGET_x86
+               depends on GRUB_IMAGES || GRUB_EFI_IMAGES
                select PACKAGE_kmod-e1000
 
                select PACKAGE_kmod-e1000
 
-       config TARGET_IMAGES_PAD
-               bool "Pad images to filesystem size (for JFFS2)"
-               depends on OLPC_BOOTSCRIPT_IMAGES || GRUB_IMAGES
-
        config TARGET_IMAGES_GZIP
                bool "GZip images"
        config TARGET_IMAGES_GZIP
                bool "GZip images"
-               depends on TARGET_IMAGES_PAD || TARGET_ROOTFS_EXT4FS
+               depends on TARGET_ROOTFS_EXT4FS || TARGET_x86 || TARGET_armvirt || TARGET_malta
                default y
 
        comment "Image Options"
                default y
 
        comment "Image Options"
@@ -254,65 +267,24 @@ menu "Target Images"
 
        config TARGET_KERNEL_PARTSIZE
                int "Kernel partition size (in MB)"
 
        config TARGET_KERNEL_PARTSIZE
                int "Kernel partition size (in MB)"
-               depends on OLPC_BOOTSCRIPT_IMAGES || GRUB_IMAGES
-               default 4
+               depends on USES_BOOT_PART
+               default 8 if TARGET_apm821xx_sata
+               default 64 if TARGET_bcm27xx
+               default 16
 
        config TARGET_ROOTFS_PARTSIZE
                int "Root filesystem partition size (in MB)"
 
        config TARGET_ROOTFS_PARTSIZE
                int "Root filesystem partition size (in MB)"
-               depends on GRUB_IMAGES || TARGET_ROOTFS_EXT4FS || TARGET_rb532
-               default 48
+               depends on USES_ROOTFS_PART || TARGET_ROOTFS_EXT4FS || TARGET_omap || TARGET_rb532 || TARGET_sunxi || TARGET_uml
+               default 104
                help
                  Select the root filesystem partition size.
 
        config TARGET_ROOTFS_PARTNAME
                string "Root partition on target device"
                help
                  Select the root filesystem partition size.
 
        config TARGET_ROOTFS_PARTNAME
                string "Root partition on target device"
-               depends on OLPC_BOOTSCRIPT_IMAGES || GRUB_IMAGES
-               default "/dev/xvda2" if TARGET_x86_xen_domu
-               default "/dev/sda2" if TARGET_x86 && ! TARGET_x86_xen_domu
+               depends on GRUB_IMAGES || GRUB_EFI_IMAGES
                help
                  Override the root partition on the final device. If left empty,
                  it will be mounted by PARTUUID which makes the kernel find the
                  appropriate disk automatically.
 
                help
                  Override the root partition on the final device. If left empty,
                  it will be mounted by PARTUUID which makes the kernel find the
                  appropriate disk automatically.
 
-
-       menuconfig TARGET_ROOTFS_INCLUDE_KERNEL
-               bool "Include kernel in root filesystem"
-               depends on TARGET_ROOTFS_UBIFS || TARGET_ROOTFS_EXT4FS
-               default n
-               help
-                 Include the kernel image in the rootfs. Typically, the image is placed
-                 below /boot.
-
-               config TARGET_ROOTFS_INCLUDE_UIMAGE
-                       bool "include uImage" if TARGET_ROOTFS_INCLUDE_KERNEL
-                       default y
-                       help
-                         This option might not apply to all targets. Make sure
-                         to check target/linux/<your_target>/image/Makefile to
-                         see if this option will have any effect.
-
-               config TARGET_ROOTFS_INCLUDE_ZIMAGE
-                       bool "include zImage" if TARGET_ROOTFS_INCLUDE_KERNEL
-                       default y
-                       help
-                         This option might not apply to all targets. Make sure
-                         to check target/linux/<your_target>/image/Makefile to
-                         see if this option will have any effect.
-
-               config TARGET_ROOTFS_INCLUDE_FIT
-                       bool "include FIT" if TARGET_ROOTFS_INCLUDE_KERNEL
-                       default y
-                       help
-                         This option might not apply to all targets. Make sure
-                         to check target/linux/<your_target>/image/Makefile to
-                         see if this option will have any effect.
-
-       config TARGET_ROOTFS_INCLUDE_DTB
-               bool "Include DTB in root filesystem"
-               depends on USES_DEVICETREE && (TARGET_ROOTFS_UBIFS || TARGET_ROOTFS_EXT4FS)
-               default n
-               help
-                 Include the device tree blob file(s) in the rootfs. Typically the DTBs
-                 are placed below /boot.
-
 endmenu
 endmenu