treewide: remove AUTORELEASE
[feed/routing.git] / mcproxy / Makefile
index b96268ab065db7d93eb1dab92f120594ff375e94..97831f7ba6c1423b0c72e6de3cf52c0d42d0264b 100644 (file)
@@ -1,5 +1,5 @@
 #
 #
-# Copyright (C) 2006-2011 OpenWrt.org
+# Copyright (C) 2014-2017 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,16 +8,17 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=mcproxy
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=mcproxy
-PKG_SOURCE_VERSION:=986523a5d714be5cf6f65e4399045cbfecd415fd
-PKG_VERSION:=2014-03-25-$(PKG_SOURCE_VERSION)
-PKG_RELEASE:=1
+PKG_RELEASE:=9
 
 PKG_SOURCE_PROTO:=git
 
 PKG_SOURCE_PROTO:=git
-PKG_SOURCE_URL:=git://github.com/mcproxy/mcproxy.git
-PKG_MAINTAINER:=Steven Barth <cyrus@openwrt.org>
+PKG_SOURCE_URL:=https://github.com/mcproxy/mcproxy.git
+PKG_SOURCE_DATE:=2017-08-24
+PKG_SOURCE_VERSION:=93b5ace42268160ebbfff4c61818fb15fa2d9b99
+PKG_MIRROR_HASH:=d9f41f93d471b3c92debffe734f48f03f5c6c6e90bb173993f44b33e699387f9
 
 
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
-PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
+PKG_MAINTAINER:=Steven Barth <cyrus@openwrt.org>
+PKG_LICENSE:=GPL-2.0-or-later
+PKG_LICENSE_FILES:=COPYING
 
 include $(INCLUDE_DIR)/package.mk
 include $(INCLUDE_DIR)/cmake.mk
 
 include $(INCLUDE_DIR)/package.mk
 include $(INCLUDE_DIR)/cmake.mk
@@ -25,24 +26,29 @@ include $(INCLUDE_DIR)/cmake.mk
 define Package/mcproxy
   SECTION:=net
   CATEGORY:=Network
 define Package/mcproxy
   SECTION:=net
   CATEGORY:=Network
+  SUBMENU:=Routing and Redirection
   TITLE:=Multicast Proxy for IGMP/MLD
   TITLE:=Multicast Proxy for IGMP/MLD
-  URL:=http://mcproxy.realmv6.org
-  DEPENDS:=+libpthread +libstdcpp
+  URL:=https://mcproxy.realmv6.org
+  DEPENDS:=+libpthread +libstdcpp @(!GCC_VERSION_4_4&&!GCC_VERSION_4_6)
 endef
 
 define Package/mcproxy/description
 endef
 
 define Package/mcproxy/description
- mcproxy is a free & open source implementation of the IGMP/MLD proxy function (see  RFC 4605) for Linux systems.
- It operates on the kernel tables for multicast routing and allows for multiple instantiations,
- as well as dynamically changing downstream interfaces.
 mcproxy is a free & open source implementation of the IGMP/MLD proxy function (see  RFC 4605) for Linux systems.
 It operates on the kernel tables for multicast routing and allows for multiple instantiations,
 as well as dynamically changing downstream interfaces.
 endef
 
 define Package/mcproxy/conffiles
 /etc/mcproxy.conf
 endef
 
 define Package/mcproxy/conffiles
 /etc/mcproxy.conf
+/etc/config/mcproxy
 endef
 
 define Package/mcproxy/install
 endef
 
 define Package/mcproxy/install
+       $(INSTALL_DIR) $(1)/etc
+       $(INSTALL_CONF) ./files/mcproxy.conf $(1)/etc/mcproxy.conf
+       $(INSTALL_DIR) $(1)/etc/config
+       $(INSTALL_CONF) ./files/mcproxy.config $(1)/etc/config/mcproxy
        $(INSTALL_DIR) $(1)/etc/init.d
        $(INSTALL_DIR) $(1)/etc/init.d
-       $(INSTALL_CONF) ./files/mcproxy.conf $(1)/etc
        $(INSTALL_BIN) ./files/mcproxy.init $(1)/etc/init.d/mcproxy
        $(INSTALL_DIR) $(1)/usr/sbin
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/mcproxy-bin $(1)/usr/sbin/mcproxy
        $(INSTALL_BIN) ./files/mcproxy.init $(1)/etc/init.d/mcproxy
        $(INSTALL_DIR) $(1)/usr/sbin
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/mcproxy-bin $(1)/usr/sbin/mcproxy