[packages] rtorrent: update to 0.8.6_r1130 (#6685)
[openwrt/svn-archive/archive.git] / Xorg / lib / xcbproto / Makefile
index 0ee335e5f7b4d3121d4ace5791e2214202e949bb..c4bd27ee388625ee656bc97f0bb91f487f0f6d5c 100644 (file)
@@ -4,7 +4,6 @@
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id: Makefile 12846 2008-10-03 22:38:55Z lars $
 
 include $(TOPDIR)/rules.mk
 
@@ -14,41 +13,38 @@ PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=http://xcb.freedesktop.org/dist/
-PKG_MD5SUM:=
-PKG_FIXUP:=libtool
+PKG_MD5SUM:=d9275a714e83ab9c1f9b260c6eff1609
 PKG_INSTALL:=1
 
-include $(INCLUDE_DIR)/package.mk
-
-
-TARGET_CFLAGS+=\
-       -I$(STAGING_DIR)/usr/lib/libintl/include/
+PKG_BUILD_DEPENDS:=PACKAGE_python:python PACKAGE_python-mini:python
 
-EXTRA_LDFLAGS+=\
-       -Wl,-rpath-link=$(STAGING_DIR)/usr/lib \
+include $(INCLUDE_DIR)/package.mk
+-include $(if $(DUMP),,$(STAGING_DIR)/mk/python-package.mk)
 
-STAMP_CONFIGURED:=$(STAMP_CONFIGURED)_$(call confvar,CONFIG_PACKAGE_xcbproto CONFIG_PACKAGE_gtk-cups2)
+STAMP_CONFIGURED:=$(STAMP_CONFIGURED)_$(call confvar,PACKAGE_python PACKAGE_python-mini)
 
 define Package/xcbproto
   SECTION:=xorg-libs
   CATEGORY:=Xorg
-  SUBMENU:=lib
+  SUBMENU:=libraries
+  BUILDONLY:=1
   TITLE:=xcbproto
-  DEPENDS:=
 endef
 
-define Build/Configure
-       $(call Build/Configure/Default, \
-       )
-endef
+ifneq ($(CONFIG_PACKAGE_python)$(CONFIG_PACKAGE_python-mini),)
+  define InstallPy
+       $(INSTALL_DIR) $(1)/host/lib/$(PYTHON)/site-packages/xcbgen
+       $(INSTALL_DATA) \
+               $(PKG_INSTALL_DIR)/usr/lib/$(PYTHON)/site-packages/xcbgen/*.py \
+               $(1)/host/lib/$(PYTHON)/site-packages/xcbgen/
+  endef
+endif
 
 define Build/InstallDev
-       $(INSTALL_DIR) $(1)/usr/lib/pkgconfig
-       $(INSTALL_DIR) $(1)/host/{lib/python2.5/site-packages/xcbgen,share/xcb}
-
-       $(INSTALL_DATA) \
-               $(PKG_INSTALL_DIR)/usr/lib/python2.5/site-packages/xcbgen/*.py \
-               $(1)/host/lib/python2.5/site-packages/xcbgen/
+       $(call InstallPy,$(1),$(2))
+       $(INSTALL_DIR) \
+               $(1)/usr/lib/pkgconfig \
+               $(1)/host/share/xcb
 
        $(INSTALL_DATA) \
                $(PKG_INSTALL_DIR)/usr/share/xcb/* \
@@ -61,9 +57,4 @@ define Build/InstallDev
        $(SED) 's,datadir=/usr,datadir=$(STAGING_DIR)/host,g' $(1)/usr/lib/pkgconfig/xcb-proto.pc
 endef
 
-define Package/xcbproto/install
-       true
-endef
-
-
 $(eval $(call BuildPackage,xcbproto))