[packages] xkeyboard-config: misc fixes:
[openwrt/svn-archive/archive.git] / Xorg / xorg / data / xkeyboard-config / Makefile
index be355b7850e23ce2a12d0ffaa6c96f3b3f661bbb..dbbc14c7e26250da1cbc21666edc59dca9ea77f0 100644 (file)
@@ -13,8 +13,9 @@ PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=http://xlibs.freedesktop.org/xkbdesc/
-PKG_INSTALL:=1
+PKG_MD5SUM:=d351c0109fac166edcedad32d1b0e38e
 
+PKG_INSTALL:=1
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -26,13 +27,13 @@ define Package/xkeyboard-config
   URL:=http://freedesktop.org/wiki/Software/XKeyboardConfig
 endef
 
-define Build/Configure
-       $(call Build/Configure/Default)
-endef
 define Package/xkeyboard-config/install
-  $(INSTALL_DIR) $(1)/usr/share/X11/xkb
-    $(CP) -v $(PKG_INSTALL_DIR)/usr/share/X11/xkb \
-      $(1)/usr/share/X11/
+       $(INSTALL_DIR) $(1)/usr/share/X11
+       $(CP) $(PKG_INSTALL_DIR)/usr/share/X11/xkb $(1)/usr/share/X11/
 endef
 
+$(eval $(call RequireCommand,intltool-update, \
+       $(PKG_NAME) requires intltool installed on the host-system. \
+))
+
 $(eval $(call BuildPackage,xkeyboard-config))