[packages] click: store the git hash in the PKG_REV variable, add PKG_RELEASE, remove...
[openwrt/svn-archive/archive.git] / admin / htop / Makefile
index 1bda9897aeef2c079fc718905776dce4d2c9e8b2..d808a22510c85d73f0d6eabe30cc346ef1b67011 100644 (file)
@@ -1,42 +1,45 @@
 #
-# Copyright (C) 2007 OpenWrt.org
+# Copyright (C) 2007-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=htop
-PKG_VERSION:=0.6.6
-PKG_RELEASE:=1
+PKG_VERSION:=0.8.3
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=@SF/htop
-PKG_MD5SUM:=12c8e6e97bd50a4e0a4730d23675fc7b
+PKG_SOURCE_URL:=@SF/$(PKG_NAME)
+PKG_MD5SUM:=5c9f093f9eaddf6e77aa6d54c2116d0c
+
+PKG_FIXUP:=libtool
 
 include $(INCLUDE_DIR)/package.mk
 
 define Package/htop
   SECTION:=admin
   CATEGORY:=Administration
-  TITLE:=process viewer
+  TITLE:=Interactive processes viewer
   DEPENDS:=+libncurses
   URL:=http://htop.sourceforge.net/
 endef
 
 define Package/htop/description
-       An interactive process viewer with colors tree mode and other features.
+ Htop is an ncursed-based process viewer similar to top, but
+ it allows to scroll the list vertically and horizontally to
+ see all processes and their full command lines.
 endef
 
-define Build/Compile
-       $(MAKE) -C $(PKG_BUILD_DIR) all
-endef
+CONFIGURE_VARS += \
+       ac_cv_file__proc_stat=yes \
+       ac_cv_file__proc_meminfo=yes \
 
-define Package/htop/install    
+define Package/htop/install
        $(INSTALL_DIR) $(1)/usr/bin
-       $(INSTALL_BIN) $(PKG_BUILD_DIR)/htop $(1)/usr/bin/
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/$(PKG_NAME) $(1)/usr/bin/
 endef
 
 $(eval $(call BuildPackage,htop))