babeld: add ubus bindings
[feed/routing.git] / babeld / Makefile
index 022d0b8471169b5901a786fa1c87680131c32294..43d9133e4865dfc3f2b73830541ea6fd094018d0 100644 (file)
@@ -8,12 +8,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=babeld
-PKG_VERSION:=1.9.1
-PKG_RELEASE:=1
+PKG_VERSION:=1.9.2
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=https://www.irif.fr/~jch/software/files/
-PKG_HASH:=1e1b3c01dd929177bc8d027aff1494da75e1e567e1f60df3bb45a78d5f1ca0b4
+PKG_HASH:=154f00e0a8bf35d6ea9028886c3dc5c3c342dd1a367df55ef29a547b75867f07
 
 PKG_MAINTAINER:=Gabriel Kerneis <gabriel@kerneis.info>, \
        Baptiste Jonglez <openwrt-pkg@bitsofnetworks.org>
@@ -28,7 +28,7 @@ define Package/babeld
   SUBMENU:=Routing and Redirection
   TITLE:=A loop-avoiding distance-vector routing protocol
   URL:=https://www.irif.fr/~jch/software/babel/
-  DEPENDS:=@IPV6
+  DEPENDS:=@IPV6 +libubus +libubox
 endef
 
 define Package/babeld/description
@@ -47,6 +47,7 @@ endef
 MAKE_FLAGS+= \
        CFLAGS="$(TARGET_CFLAGS)" \
        LDLIBS="" \
+       LDLIBS+="-lubus -lubox"
 
 define Package/babeld/install
        $(INSTALL_DIR) $(1)/usr/sbin