Add support for Branch Target Identification
[project/bcm63xx/atf.git] / bl32 / tsp / tsp.mk
index b1fe7ff600e930f28360019f7a5ea477cd1ac4f3..3fd6d99577cfb7cb7fa0b45afe425e4fd915eedd 100644 (file)
@@ -17,11 +17,6 @@ BL32_SOURCES         +=      bl32/tsp/tsp_main.c                     \
 
 BL32_LINKERFILE                :=      bl32/tsp/tsp.ld.S
 
-# This flag determines whether pointer authentication is used in the TSP or not
-ifeq ($(ENABLE_PAUTH),1)
-BL32_CFLAGS            +=      -msign-return-address=non-leaf
-endif
-
 # This flag determines if the TSPD initializes BL32 in tspd_init() (synchronous
 # method) or configures BL31 to pass control to BL32 instead of BL33
 # (asynchronous method).