Add sha256 ckecksums to okpg
[project/opkg-lede.git] / configure.ac
index 315e13974d114ea62fc66050b0a032739ee1fd8e..9c108f3f8dd27d5f1c7e4313d9df70a2bd324c90 100644 (file)
@@ -37,6 +37,17 @@ if test "x$want_curl" = "xyes"; then
   AC_DEFINE(HAVE_CURL, 1, [Define if you want CURL support])
 fi
 
+# check for sha256
+AC_ARG_ENABLE(sha256,
+              AC_HELP_STRING([--enable-sha256], [Enable sha256sum check
+      [[default=yes]] ]),
+    [want_sha256="$enableval"], [want_sha256="yes"])
+
+if test "x$want_sha256" = "xyes"; then
+  AC_DEFINE(HAVE_SHA256, 1, [Define if you want sha256 support])
+fi
+AM_CONDITIONAL(HAVE_SHA256, test "x$want_sha256" = "xyes")
+
 
 dnl **********
 dnl GPGME
@@ -127,8 +138,9 @@ opkglibdir=
 AC_ARG_WITH(opkglibdir,
 [  --with-opkglibdir=DIR   specifies directory to put status and info files.
                           "/opkg" is always added so if you want your files 
-                          to be in /usr/lib/opkg you should indicate 
-                          --with-opkglibdir=/usr/lib ],
+                          to be in /var/lib/opkg instead of /usr/lib/opkg
+                          you should indicate 
+                          --with-opkglibdir=/var/lib ],
 [case "${withval}" in
 yes)    AC_MSG_ERROR(bad value ${withval} given for opkg libs directories ) ;;
 no)     ;;
@@ -140,7 +152,27 @@ if test x$opkglibdir = x; then
         opkglibdir=/usr/lib
 fi
 
+ipkgetcdir=
+AC_ARG_WITH(opkgetcdir,
+[  --with-ipkgetcdir=DIR   specifies directory for opkg.conf file,
+                           "/opkg" is always added so if you want your files
+                           to be in /usr/etc/opkg instead of /etc/opkg
+                           you should indicate
+                           --with-ipkgetcdir=/usr/etc ],
+[case "${withval}" in
+yes)    AC_MSG_ERROR(bad value ${withval} given for opkg.conf directory ) ;;
+no)     ;;
+*)      opkgetcdir=$with_opkgetcdir ;;
+esac])
+
+# Default local prefix if it is empty
+if test x$opkgetcdir = x; then
+        opkgetcdir=/etc
+fi
+
+
 AC_SUBST(opkglibdir)
+AC_SUBST(opkgetcdir)
 
 AC_OUTPUT(
     Makefile