update nfs-kernel-server to 1.1.6
[openwrt/svn-archive/archive.git] / devel / binutils / Makefile
index 16b39bcf684248238502e1f91085a89ff2070489..98525cb85cb1221301745505a0eccb0586470eb7 100644 (file)
@@ -10,9 +10,15 @@ PKG_NAME:=binutils
 PKG_VERSION:=$(strip $(subst ",, $(CONFIG_BINUTILS_VERSION)))
 #"))
 PKG_RELEASE:=2
+
 PKG_SOURCE_URL:=@GNU/binutils
 PKG_SOURCE:=binutils-$(PKG_VERSION).tar.bz2
+PKG_MD5SUM:=
+
 PATCH_DIR:=$(TOPDIR)/toolchain/binutils/patches/$(PKG_VERSION)
+
+PKG_FIXUP:=libtool
+PKG_LIBTOOL_PATHS:=. gas bfd opcodes gprof binutils ld
 PKG_INSTALL:=1
 
 include $(INCLUDE_DIR)/package.mk
@@ -35,12 +41,6 @@ define Package/binutils/description
   The Binutils package contains a linker, an assembler, and other tools for handling object files
 endef
 
-define Package/libbfd
-  SECTION:=libs
-  CATEGORY:=Libraries
-  TITLE:=libbfd
-endef
-
 TARGET_CFLAGS += $(FPIC)
 
 define Build/Configure
@@ -48,6 +48,18 @@ define Build/Configure
                --disable-werror \
                --disable-nls \
        )
+       $(call Build/Compile/Default, \
+               configure-bfd \
+               configure-binutils \
+               configure-etc \
+               configure-gas \
+               configure-gprof \
+               configure-intl \
+               configure-ld \
+               configure-libiberty \
+               configure-opcodes \
+       )
+       $(MAKE) -C $(PKG_BUILD_DIR)/bfd/po Makefile
 endef
 
 define Build/InstallDev
@@ -61,6 +73,7 @@ define Build/InstallDev
        $(CP) \
                $(PKG_INSTALL_DIR)/usr/include/* \
                $(1)/usr/include/
+       rm -f $(1)/usr/include/gdbm.h
 endef
 
 define Build/Compile
@@ -80,10 +93,5 @@ define Package/binutils/install
        rm -f $(1)/usr/bin/objdump
 endef
 
-define Package/libbfd/install
-    true
-endef
-
 $(eval $(call BuildPackage,binutils))
 $(eval $(call BuildPackage,objdump))
-$(eval $(call BuildPackage,libbfd))