lldpd: Use /etc/os-release instead of /etc/openwrt_*
[openwrt/staging/florian.git] / include / feeds.mk
index a5ce877967f450b13a155d4d9bac059981d2f2b2..9526e347062dfb731349413b7f23093eb13e7495 100644 (file)
@@ -8,8 +8,8 @@
 
 -include $(TMP_DIR)/.packagesubdirs
 
-FEEDS_AVAILABLE:=$(shell $(SCRIPT_DIR)/feeds list -n)
 FEEDS_INSTALLED:=$(notdir $(wildcard $(TOPDIR)/package/feeds/*))
+FEEDS_AVAILABLE:=$(sort $(FEEDS_INSTALLED) $(shell $(SCRIPT_DIR)/feeds list -n))
 FEEDS_ENABLED:=$(foreach feed,$(FEEDS_INSTALLED),$(if $(CONFIG_FEED_$(feed)),$(feed)))
 FEEDS_DISABLED:=$(filter-out $(FEEDS_ENABLED),$(FEEDS_AVAILABLE))
 
@@ -30,8 +30,6 @@ PKG_CONFIG_DEPENDS += \
        $(foreach feed,$(FEEDS_INSTALLED),CONFIG_FEED_$(feed))
 
 # 1: package name
-# 2: flags
-# 3: section
 define FeedPackageDir
 $(strip $(if $(CONFIG_PER_FEED_REPO), \
   $(if $(Package/$(1)/subdir), \