use PREFIX/bin instead of PREFIX/sbin for all host builds (fixes e2fsprogs path)
[openwrt/staging/florian.git] / include / host-build.mk
index 1b7f354066ece81a3aa0f131bd61baba3d24c33b..161192c3bb71d28f106b01f02e78ca69cfec3d54 100644 (file)
@@ -58,7 +58,8 @@ HOST_CONFIGURE_ARGS = \
        --prefix=$(STAGING_DIR_HOST) \
        --exec-prefix=$(STAGING_DIR_HOST) \
        --sysconfdir=$(STAGING_DIR_HOST)/etc \
-       --localstatedir=$(STAGING_DIR_HOST)/var
+       --localstatedir=$(STAGING_DIR_HOST)/var \
+       --sbindir=$(STAGING_DIR_HOST)/bin
 
 HOST_CONFIGURE_CMD = ./configure
 
@@ -153,12 +154,12 @@ ifndef DUMP
                $(call Host/Compile)
                touch $$@
 
-    $(HOST_STAMP_INSTALLED): $(HOST_STAMP_BUILT)
+    $(HOST_STAMP_INSTALLED): $(HOST_STAMP_BUILT) $(if $(FORCE_HOST_INSTALL),FORCE)
                $(call Host/Install)
                mkdir -p $$(shell dirname $$@)
                touch $$@
   else
-    $(HOST_STAMP_BUILT): $(HOST_STAMP_CONFIGURED)
+    $(HOST_STAMP_BUILT): $(HOST_STAMP_CONFIGURED) $(if $(FORCE_HOST_INSTALL),FORCE)
                $(call Host/Compile)
                $(call Host/Install)
                touch $$@