bcm63xx: a226m-fwb: fix linux partition offset
[openwrt/staging/adrian.git] / include / image-commands.mk
index c6b4b23ce3cf5e7e5ea91a6ae49940e4833889b5..182f5f831db5614c27e20dd5b8533653f336abdc 100644 (file)
@@ -120,7 +120,7 @@ define Build/append-uImage-fakehdr
 endef
 
 define Build/tplink-safeloader
-       -$(STAGING_DIR_HOST)/bin/tplink-safeloader \
+       -$(STAGING_DIR_HOST)/bin/tplink-safeloader \
                -B $(TPLINK_BOARD_ID) \
                -V $(REVISION) \
                -k $(IMAGE_KERNEL) \
@@ -355,11 +355,13 @@ json_quote=$(subst ','\'',$(subst ",\",$(1)))
 metadata_devices=$(if $(1),$(subst "$(space)","$(comma)",$(strip $(foreach v,$(1),"$(call json_quote,$(v))"))))
 metadata_json = \
        '{ $(if $(IMAGE_METADATA),$(IMAGE_METADATA)$(comma)) \
+               "metadata_version": "1.0", \
                "supported_devices":[$(call metadata_devices,$(1))], \
                "version": { \
                        "dist": "$(call json_quote,$(VERSION_DIST))", \
                        "version": "$(call json_quote,$(VERSION_NUMBER))", \
                        "revision": "$(call json_quote,$(REVISION))", \
+                       "target": "$(call json_quote,$(TARGETID))", \
                        "board": "$(call json_quote,$(if $(BOARD_NAME),$(BOARD_NAME),$(DEVICE_NAME)))" \
                } \
        }'