ath79: reduce spi-max-frequency to 50 MHz
[openwrt/staging/wigyori.git] / include / image-commands.mk
index 1d0aed1918f53199357512167ba1b19968c0731c..37cb083bbfbca2c6c62305f20d3840ddc476eb1f 100644 (file)
@@ -3,6 +3,10 @@
 IMAGE_KERNEL = $(word 1,$^)
 IMAGE_ROOTFS = $(word 2,$^)
 
+define rootfs_align
+$(patsubst %-256k,0x40000,$(patsubst %-128k,0x20000,$(patsubst %-64k,0x10000,$(patsubst squashfs%,0x4,$(patsubst root.%,%,$(1))))))
+endef
+
 define Build/uImage
        mkimage -A $(LINUX_KARCH) \
                -O linux -T kernel \
@@ -109,10 +113,13 @@ endef
 # append a fake/empty uImage header, to fool bootloaders rootfs integrity check
 # for example
 define Build/append-uImage-fakehdr
+       $(eval type=$(word 1,$(1)))
+       $(eval magic=$(word 2,$(1)))
        touch $@.fakehdr
        $(STAGING_DIR_HOST)/bin/mkimage \
-               -A $(LINUX_KARCH) -O linux -T $(1) -C none \
-               -n '$(VERSION_DIST) fake $(1)' \
+               -A $(LINUX_KARCH) -O linux -T $(type) -C none \
+               -n '$(VERSION_DIST) fake $(type)' \
+               $(if $(magic),-M $(magic)) \
                -d $@.fakehdr \
                -s \
                $@.fakehdr
@@ -268,6 +275,13 @@ define Build/check-size
        }
 endef
 
+define Build/check-kernel-size
+       @[ $$(($(subst k,* 1024,$(subst m, * 1024k,$(1))))) -ge "$$(stat -c%s $(IMAGE_KERNEL))" ] || { \
+               echo "WARNING: Kernel for $@ is too big > $(1)" >&2; \
+               rm -f $@; \
+       }
+endef
+
 define Build/combined-image
        -sh $(TOPDIR)/scripts/combined-image.sh \
                "$(IMAGE_KERNEL)" \
@@ -332,6 +346,24 @@ define Build/tplink-v1-header
        @mv $@.new $@
 endef
 
+# combine kernel and rootfs into one image
+# mktplinkfw <type> <optional extra arguments to mktplinkfw binary>
+# <type> is "sysupgrade" or "factory"
+#
+# -a align the rootfs start on an <align> bytes boundary
+# -j add jffs2 end-of-filesystem markers
+# -s strip padding from end of the image
+# -X reserve <size> bytes in the firmware image (hexval prefixed with 0x)
+define Build/tplink-v1-image
+       -$(STAGING_DIR_HOST)/bin/mktplinkfw \
+               -H $(TPLINK_HWID) -W $(TPLINK_HWREV) -F $(TPLINK_FLASHLAYOUT) \
+               -N "$(VERSION_DIST)" -V $(REVISION) -m $(TPLINK_HEADER_VERSION) \
+               -k $(IMAGE_KERNEL) -r $(IMAGE_ROOTFS) -o $@.new -j -X 0x40000 \
+               -a $(call rootfs_align,$(FILESYSTEM)) \
+               $(wordlist 2,$(words $(1)),$(1)) \
+               $(if $(findstring sysupgrade,$(word 1,$(1))),-s) && mv $@.new $@ || rm -f $@
+endef
+
 define Build/tplink-v2-header
        $(STAGING_DIR_HOST)/bin/mktplinkfw2 \
                -c -H $(TPLINK_HWID) -W $(TPLINK_HWREV) -L $(KERNEL_LOADADDR) \