bcm53xx: switch USB 3.0 PHY DT description to use MDIO bus
[openwrt/staging/chunkeey.git] / include / image-commands.mk
index 82ceacd80eaa0aa3f7a39f6c3d770d4c72070086..4d3f025b123f44cfd48d5b6cf081ae7633577277 100644 (file)
@@ -60,7 +60,7 @@ endef
 
 define Build/netgear-dni
        $(STAGING_DIR_HOST)/bin/mkdniimg \
-               -B $(NETGEAR_BOARD_ID) -v $(VERSION_DIST).$(REVISION) \
+               -B $(NETGEAR_BOARD_ID) -v $(VERSION_DIST).$(firstword $(subst -, ,$(REVISION))) \
                $(if $(NETGEAR_HW_ID),-H $(NETGEAR_HW_ID)) \
                -r "$(1)" \
                -i $@ -o $@.new
@@ -135,7 +135,7 @@ define Build/lzma-no-dict
 endef
 
 define Build/gzip
-       gzip --force -9n -c $@ $(1) > $@.new
+       gzip -f -9n -c $@ $(1) > $@.new
        @mv $@.new $@
 endef