build: fix uImage fake header command
[openwrt/staging/dedeckeh.git] / include / image-commands.mk
index 0f9ac0836cedb5b6d5ac9b327fba1df65ebc72ae..5f7845a6d921740f56e4b4f52db4e769557d1d61 100644 (file)
@@ -80,10 +80,11 @@ endef
 # append a fake/empty rootfs uImage header, to fool the bootloaders
 # rootfs integrity check
 define Build/append-uImage-fakeroot-hdr
-       rm -f $@.fakeroot
+       touch $@.fakeroot
        $(STAGING_DIR_HOST)/bin/mkimage \
                -A $(LINUX_KARCH) -O linux -T filesystem -C none \
                -n '$(call toupper,$(LINUX_KARCH)) $(VERSION_DIST) fakeroot' \
+               -d $@.fakeroot \
                -s \
                $@.fakeroot
        cat $@.fakeroot >> $@