scripts: mkits.sh make it possible to specify fdt@#
[openwrt/staging/zorun.git] / include / image-commands.mk
index 9516801c8dfd596e5f2c251b15c013c2a26e0642..740d627fc735cb32d9a5297fd688ab86481166db 100644 (file)
@@ -158,6 +158,7 @@ define Build/fit
                -D $(DEVICE_NAME) -o $@.its -k $@ \
                $(if $(word 2,$(1)),-d $(word 2,$(1))) -C $(word 1,$(1)) \
                -a $(KERNEL_LOADADDR) -e $(if $(KERNEL_ENTRY),$(KERNEL_ENTRY),$(KERNEL_LOADADDR)) \
+               $(if $(DEVICE_FDT_NUM),-n $(DEVICE_FDT_NUM)) \
                -c $(if $(DEVICE_DTS_CONFIG),$(DEVICE_DTS_CONFIG),"config@1") \
                -A $(LINUX_KARCH) -v $(LINUX_VERSION)
        PATH=$(LINUX_DIR)/scripts/dtc:$(PATH) mkimage -f $@.its $@.new