image: add additional fields to Netgear encrypted image
[openwrt/staging/jow.git] / include / image-commands.mk
index 9220b8dec0069abef9c98b27b7d7ba04242d7c98..77a35f3eec00703ad3b61a38ff24218157d68ff6 100644 (file)
@@ -432,6 +432,8 @@ define Build/netgear-encrypted-factory
                --output-file $@ \
                --model $(NETGEAR_ENC_MODEL) \
                --region $(NETGEAR_ENC_REGION) \
+               $(if $(NETGEAR_ENC_HW_ID_LIST),--hw-id-list "$(NETGEAR_ENC_HW_ID_LIST)") \
+               $(if $(NETGEAR_ENC_MODEL_LIST),--model-list "$(NETGEAR_ENC_MODEL_LIST)") \
                --version V1.0.0.0.$(shell cat $(VERSION_DIST)| sed -e 's/[[:space:]]/-/g').$(firstword $(subst -, ,$(REVISION))) \
                --encryption-block-size 0x20000 \
                --openssl-bin "$(STAGING_DIR_HOST)/bin/openssl" \