ipq40xx: fix dtc warnimg
[openwrt/staging/hauke.git] / include / image-commands.mk
index 1d694850195457f826a975044a43a2674d6c1af2..d07c8827619fc2cb3deafa9970cf9099f23492d3 100644 (file)
@@ -226,6 +226,11 @@ define Build/copy-file
        cat "$(1)" > "$@"
 endef
 
+define Build/dlink-sge-image
+       $(STAGING_DIR_HOST)/bin/dlink-sge-image $(1) $@ $@.enc
+       mv $@.enc $@
+endef
+
 define Build/edimax-header
        $(STAGING_DIR_HOST)/bin/mkedimaximg -i $@ -o $@.new $(1)
        @mv $@.new $@
@@ -399,6 +404,15 @@ define Build/lzma-no-dict
        @mv $@.new $@
 endef
 
+define Build/moxa-encode-fw
+       $(TOPDIR)/scripts/moxa-encode-fw.py \
+               --input $@ \
+               --output $@ \
+               --magic $(MOXA_MAGIC) \
+               --hwid $(MOXA_HWID) \
+               --buildid 00000000
+endef
+
 define Build/netgear-chk
        $(STAGING_DIR_HOST)/bin/mkchkimg \
                -o $@.new \
@@ -423,6 +437,8 @@ define Build/netgear-encrypted-factory
                --output-file $@ \
                --model $(NETGEAR_ENC_MODEL) \
                --region $(NETGEAR_ENC_REGION) \
+               $(if $(NETGEAR_ENC_HW_ID_LIST),--hw-id-list "$(NETGEAR_ENC_HW_ID_LIST)") \
+               $(if $(NETGEAR_ENC_MODEL_LIST),--model-list "$(NETGEAR_ENC_MODEL_LIST)") \
                --version V1.0.0.0.$(shell cat $(VERSION_DIST)| sed -e 's/[[:space:]]/-/g').$(firstword $(subst -, ,$(REVISION))) \
                --encryption-block-size 0x20000 \
                --openssl-bin "$(STAGING_DIR_HOST)/bin/openssl" \