build: uImage: separate arguments into individual lines
[openwrt/staging/rmilecki.git] / include / image-commands.mk
index a8faefbcff6e677fdaac68846ec6d3f22c571941..de4c86c24a2effde5be0c0593fb39800cf537576 100644 (file)
@@ -394,11 +394,16 @@ define Build/tplink-v2-image
 endef
 
 define Build/uImage
-       mkimage -A $(LINUX_KARCH) \
-               -O linux -T kernel \
-               -C $(word 1,$(1)) -a $(KERNEL_LOADADDR) -e $(if $(KERNEL_ENTRY),$(KERNEL_ENTRY),$(KERNEL_LOADADDR)) \
+       mkimage \
+               -A $(LINUX_KARCH) \
+               -O linux \
+               -T kernel \
+               -C $(word 1,$(1)) \
+               -a $(KERNEL_LOADADDR) \
+               -e $(if $(KERNEL_ENTRY),$(KERNEL_ENTRY),$(KERNEL_LOADADDR)) \
                -n '$(if $(UIMAGE_NAME),$(UIMAGE_NAME),$(call toupper,$(LINUX_KARCH)) $(VERSION_DIST) Linux-$(LINUX_VERSION))' \
-               $(wordlist 2,$(words $(1)),$(1)) -d $@ $@.new
+               $(wordlist 2,$(words $(1)),$(1)) \
+               -d $@ $@.new
        mv $@.new $@
 endef