A little endian arm site defaults, in case anyone wants it. ixp4xx kernel and rootfs...
[openwrt/staging/florian.git] / include / image.mk
index 6805389d72529197c8bf5d98889fedb8a7abd46c..1c36327c61f9f3ab597a7f95cc58c9000bc8746e 100644 (file)
@@ -5,6 +5,7 @@
 # See /LICENSE for more information.
 #
 
+include $(INCLUDE_DIR)/prereq.mk
 include $(INCLUDE_DIR)/kernel.mk
 KDIR:=$(BUILD_DIR)/linux-$(KERNEL)-$(BOARD)
 
@@ -74,10 +75,12 @@ define Image/mkfs/prepare
 endef
 
 define BuildImage
-compile:
+download:
+prepare:
+compile: compile-targets
        $(call Build/Compile)
 
-install:
+install: compile install-targets
        $(call Image/Prepare)
        $(call Image/mkfs/prepare)
        $(call Image/BuildKernel)
@@ -86,16 +89,12 @@ install:
        $(call Image/mkfs/tgz)
        $(call Image/mkfs/ext2)
        
-clean:
+clean: clean-targets
        $(call Build/Clean)
-endef
 
 compile-targets:
 install-targets:
 clean-targets:
+endef
+
 
-download:
-prepare:
-compile: compile-targets
-install: compile install-targets
-clean: clean-targets