image.mk: evaluate /etc/selinux/config to choose SELinux policy
[openwrt/staging/hauke.git] / include / image.mk
index f72095db56345e1ca803a56cc93cc2416bebc7d4..28f40fe6a9901acd194788942a149caaddd4d216 100644 (file)
@@ -243,10 +243,11 @@ endef
 
 ifeq ($(CONFIG_TARGET_ROOTFS_SECURITY_LABELS),y)
 define Image/mkfs/squashfs
+       echo ". $(call mkfs_target_dir,$(1))/etc/selinux/config" > $@.fakeroot-script
        echo "$(STAGING_DIR_HOST)/bin/setfiles -r" \
             "$(call mkfs_target_dir,$(1))" \
-            "$(call mkfs_target_dir,$(1))/etc/selinux/targeted/contexts/files/file_contexts " \
-            "$(call mkfs_target_dir,$(1))" > $@.fakeroot-script
+            "$(call mkfs_target_dir,$(1))/etc/selinux/\$${SELINUXTYPE}/contexts/files/file_contexts " \
+            "$(call mkfs_target_dir,$(1))" >> $@.fakeroot-script
        echo "$(Image/mkfs/squashfs-common)" >> $@.fakeroot-script
        chmod +x $@.fakeroot-script
        $(FAKEROOT) "$@.fakeroot-script"