build: include size-limits to device-metadata
[openwrt/staging/blocktrron.git] / include / image.mk
index 096ccb5f1858c2921fac563261fee133e8c6f38b..7f61dd07f355f74f0bf4accbd51b6ef8606d8b32 100644 (file)
@@ -566,6 +566,8 @@ define Device/Build/initramfs
        VERSION_NUMBER="$(VERSION_NUMBER)" \
        VERSION_CODE="$(VERSION_CODE)" \
        SUPPORTED_DEVICES="$$(SUPPORTED_DEVICES)" \
+       KERNEL_SIZE="$$(KERNEL_SIZE)" \
+       IMAGE_SIZE="$$(IMAGE_SIZE)" \
        $(TOPDIR)/scripts/json_add_image_info.py $$@
 endef
 endif
@@ -700,6 +702,8 @@ define Device/Build/image
        VERSION_NUMBER="$(VERSION_NUMBER)" \
        VERSION_CODE="$(VERSION_CODE)" \
        SUPPORTED_DEVICES="$(SUPPORTED_DEVICES)" \
+       KERNEL_SIZE="$(KERNEL_SIZE)" \
+       IMAGE_SIZE="$(IMAGE_SIZE)" \
        $(TOPDIR)/scripts/json_add_image_info.py $$@
 
 endef
@@ -754,6 +758,8 @@ define Device/Build/artifact
        VERSION_NUMBER="$(VERSION_NUMBER)" \
        VERSION_CODE="$(VERSION_CODE)" \
        SUPPORTED_DEVICES="$(SUPPORTED_DEVICES)" \
+       KERNEL_SIZE="$(KERNEL_SIZE)" \
+       IMAGE_SIZE="$(IMAGE_SIZE)" \
        $(TOPDIR)/scripts/json_add_image_info.py $$@
 
 endef