otrx: make crc32 table global for further optimizations
[openwrt/svn-archive/archive.git] / include / image.mk
index 287c679cfd12d8cfdae0ddb46cfcdea6f7577f5b..814e7dc5d17f4e651af03e1c3aba307da4375cf2 100644 (file)
@@ -304,6 +304,11 @@ define Build/append-rootfs
        dd if=$(word 2,$^) $(if $(1),bs=$(1) conv=sync) >> $@
 endef
 
+define Build/pad-to
+       dd if=$@ of=$@.new bs=$(1) conv=sync
+       mv $@.new $@
+endef
+
 define Build/pad-rootfs
        $(call prepare_generic_squashfs,$@ $(1))
 endef