image: disable compile target within image builder
[openwrt/staging/chunkeey.git] / include / image.mk
index b8be838313c9f0a09430c3fcf739f25b5118def3..921d78d10d7b52e578b253c13f829ee48c2055dd 100644 (file)
@@ -359,7 +359,7 @@ endef
 
 define Device/Check
   _TARGET = $$(if $$(filter $(PROFILE),$$(PROFILES)),install,install-disabled)
-  _COMPILE_TARGET = $$(if $(CONFIG_IB)$$(filter $(PROFILE),$$(PROFILES)),compile,compile-disabled)
+  _COMPILE_TARGET = $$(if $(if $(IB),,$(CONFIG_IB)$$(filter $(PROFILE),$$(PROFILES))),compile,compile-disabled)
 endef
 
 ifndef IB