ar71xx: Ubiquiti Airmax M: add relocate-kernel to invalidate cache
[openwrt/staging/chunkeey.git] / include / kernel-defaults.mk
index 10bd67a571f12b2ffeb97624654f3f2c68905af4..1ba7be844898d0aa7ad3e0b223bde2ddf8c361cf 100644 (file)
@@ -165,7 +165,7 @@ endef
 ifneq ($(CONFIG_TARGET_ROOTFS_INITRAMFS),)
 define Kernel/CompileImage/Initramfs
        $(call Kernel/Configure/Initramfs)
-       $(CP) $(GENERIC_PLATFORM_DIR)/base-files/init $(TARGET_DIR)/init
+       $(CP) $(GENERIC_PLATFORM_DIR)/other-files/init $(TARGET_DIR)/init
        rm -rf $(KERNEL_BUILD_DIR)/linux-$(LINUX_VERSION)/usr/initramfs_data.cpio*
        +$(MAKE) $(KERNEL_MAKEOPTS) $(if $(KERNELNAME),$(KERNELNAME),all) modules
        $(call Kernel/CopyImage,-initramfs)