include: use libdeflate's gzip to decompress
[openwrt/staging/hauke.git] / include / kernel-defaults.mk
index 127fa8563afbc5d5b59ed772586e2af3cd57253f..37c114113952bd97929c3ee4e73e7b43b5aaf6f3 100644 (file)
@@ -21,7 +21,7 @@ Kernel/Patch:=$(Kernel/Patch/Default)
 ifneq (,$(findstring .xz,$(LINUX_SOURCE)))
   LINUX_CAT:=xzcat
 else
-  LINUX_CAT:=gzip -dc
+  LINUX_CAT:=$(STAGING_DIR_HOST)/bin/libdeflate-gzip -dc
 endif
 
 ifeq ($(strip $(CONFIG_EXTERNAL_KERNEL_TREE)),"")