cmake: the toolchain is in $(TOOLCHAIN_DIR)/usr/bin on backfire
[openwrt/svn-archive/archive.git] / include / kernel-version.mk
index 50683c54a24c18766318386a760892ef4250f588..0fdaece9057ae21b32078332fa967fa3dcd182b8 100644 (file)
@@ -1,15 +1,38 @@
 # Use the default kernel version if the Makefile doesn't override it
 
-ifeq ($(LINUX_VERSION),)
-  ifeq ($(KERNEL),2.4)
-    LINUX_VERSION:=2.4.34
-    LINUX_RELEASE:=1
-    LINUX_KERNEL_MD5SUM:=f59665540a7f3351ea416a0dad104b55
-  else
-    LINUX_VERSION:=2.6.19.1
-    LINUX_RELEASE:=1
-    LINUX_KERNEL_MD5SUM:=2ab08fdfddc00e09b3d5bc7397d3c8be
-  endif
-endif
-KERNEL:=2.$(word 2,$(subst ., ,$(strip $(LINUX_VERSION))))
+ifeq ($(KERNEL),2.4)
+  LINUX_VERSION?=2.4.37.9
+endif
+LINUX_RELEASE?=1
+
+ifeq ($(LINUX_VERSION),2.4.37.9)
+  LINUX_KERNEL_MD5SUM:=b85b8962840c13f17f944e7b1890f8f8
+endif
+ifeq ($(LINUX_VERSION),2.6.25.20)
+  LINUX_KERNEL_MD5SUM:=0da698edccf03e2235abc2830a495114
+endif
+ifeq ($(LINUX_VERSION),2.6.30.10)
+  LINUX_KERNEL_MD5SUM:=eb6be465f914275967a5602cb33662f5
+endif
+ifeq ($(LINUX_VERSION),2.6.31.12)
+  LINUX_KERNEL_MD5SUM:=517be354b81b780e2f4b2ad614d030de
+endif
+ifeq ($(LINUX_VERSION),2.6.32.27)
+  LINUX_KERNEL_MD5SUM:=c8df8bed01a3b7e4ce13563e74181d71
+endif
+ifeq ($(LINUX_VERSION),2.6.33)
+  LINUX_KERNEL_MD5SUM:=c3883760b18d50e8d78819c54d579b00
+endif
+ifeq ($(LINUX_VERSION),2.6.33.1)
+  LINUX_KERNEL_MD5SUM:=73b514ec918b88a45656be191b1ee226
+endif
+
+# disable the md5sum check for unknown kernel versions
+LINUX_KERNEL_MD5SUM?=x
+
+split_version=$(subst ., ,$(1))
+merge_version=$(subst $(space),.,$(1))
+KERNEL_BASE=$(firstword $(subst -, ,$(LINUX_VERSION)))
+KERNEL=$(call merge_version,$(wordlist 1,2,$(call split_version,$(KERNEL_BASE))))
+KERNEL_PATCHVER=$(call merge_version,$(wordlist 1,3,$(call split_version,$(KERNEL_BASE))))