add special handling for the adm5120 target, which uses subtargets for different...
[openwrt/staging/dedeckeh.git] / include / package-defaults.mk
index 3cba736f0f101d282b4033d1056ebe97f4836e11..2b5cb8671cc1e9f555fb31411547e967a4148eab 100644 (file)
@@ -23,7 +23,11 @@ define Package/Default
   else
     VERSION:=$(PKG_RELEASE)
   endif
-  PKGARCH:=$(ARCH)
+  ifneq ($(CONFIG_TARGET_adm5120),y)
+    PKGARCH:=$(BOARD)
+  else
+    PKGARCH:=$(BOARD)_$(ARCH)
+  endif
   PRIORITY:=optional
   DEFAULT:=
   MENU:=