build: only print skipped packages that were selected
[openwrt/staging/chunkeey.git] / include / package-ipkg.mk
index b8c8cd6f99cc9938fae2fdc72b37b6d3f0fd3d3d..13bb7c7d42223edfd1ed465403b9f4b447c03804 100644 (file)
@@ -109,7 +109,7 @@ ifeq ($(DUMP),)
                        echo "$(1)" >> $(PKG_INSTALL_STAMP)
         endif
       else
-        $$(info WARNING: skipping $(1) -- package not selected)
+        $(if $(CONFIG_PACKAGE_$(1)),$$(info WARNING: skipping $(1) -- package not selected))
       endif
     endif
     endif