build: stage bin/ packages inside PKG_BUILD_DIR
[openwrt/staging/lynxis/omap.git] / include / package.mk
index ea801288eadb139cc0dd2412b4c927c6bd7330e0..37cea1448df8339f9eb2d325bbac70b04dc537ad 100644 (file)
@@ -143,6 +143,7 @@ Build/Exports=$(Build/Exports/Default)
 define Build/CoreTargets
   $(if $(QUILT),$(Build/Quilt))
   $(call Build/Autoclean)
+  $(call DefaultTargets)
 
   download:
        $(foreach hook,$(Hooks/Download),
@@ -203,13 +204,13 @@ define Build/CoreTargets
        touch $$@
 
   ifdef Build/InstallDev
-    compile: $(STAMP_INSTALLED)
+    .compile: $(STAMP_INSTALLED)
   endif
 
-  prepare: $(STAMP_PREPARED)
-  configure: $(STAMP_CONFIGURED)
-  dist: $(STAMP_CONFIGURED)
-  distcheck: $(STAMP_CONFIGURED)
+  .prepare: $(STAMP_PREPARED)
+  .configure: $(STAMP_CONFIGURED)
+  .dist: $(STAMP_CONFIGURED)
+  .distcheck: $(STAMP_CONFIGURED)
 endef
 
 define Build/DefaultTargets
@@ -287,11 +288,8 @@ prepare-package-install:
 $(PACKAGE_DIR):
        mkdir -p $@
 
-dumpinfo:
-download:
-prepare:
-configure:
 compile: prepare-package-install
+.install: .compile
 install: compile
 
 clean: FORCE