ps3: build-in ps3 system manager
[openwrt/staging/dedeckeh.git] / include / prereq-build.mk
index 6311e601ba46410bad706961fdac380adc12d81d..1e448d393f699f121ee3cb21ffc55a835adb8b93 100644 (file)
@@ -52,7 +52,8 @@ $(eval $(call Require,working-gcc, \
 
 define Require/working-g++
        echo 'int main(int argc, char **argv) { return 0; }' | \
-               g++ -x c++ -o $(TMP_DIR)/a.out -lstdc++ -
+               g++ -x c++ -o $(TMP_DIR)/a.out -lstdc++ - && \
+               $(TMP_DIR)/a.out
 endef
 
 $(eval $(call Require,working-g++, \
@@ -118,6 +119,10 @@ $(eval $(call Require,gnutar, \
        Please install GNU tar. \
 ))
 
+$(eval $(call RequireCommand,svn, \
+       Please install the subversion client. \
+))
+
 $(eval $(call RequireCommand,autoconf, \
        Please install GNU autoconf. \
 ))