build: add GCC 10 version detection
[openwrt/staging/jow.git] / include / prereq-build.mk
index cbfc62397e8ba96fa708cc9cf84c1ea304974199..89cc849cc1c22b525912699deb65a1a515195e93 100644 (file)
@@ -28,8 +28,8 @@ $(eval $(call TestHostCommand,proper-umask, \
 
 $(eval $(call SetupHostCommand,gcc, \
        Please install the GNU C Compiler (gcc) 4.8 or later, \
-       $(CC) -dumpversion | grep -E '^(4\.[8-9]|[5-9]\.?)', \
-       gcc -dumpversion | grep -E '^(4\.[8-9]|[5-9]\.?)', \
+       $(CC) -dumpversion | grep -E '^(4\.[8-9]|[5-9]\.?|10\.?)', \
+       gcc -dumpversion | grep -E '^(4\.[8-9]|[5-9]\.?|10\.?)', \
        gcc48 --version | grep gcc, \
        gcc49 --version | grep gcc, \
        gcc5 --version | grep gcc, \
@@ -37,6 +37,7 @@ $(eval $(call SetupHostCommand,gcc, \
        gcc7 --version | grep gcc, \
        gcc8 --version | grep gcc, \
        gcc9 --version | grep gcc, \
+       gcc10 --version | grep gcc, \
        gcc --version | grep -E 'Apple.(LLVM|clang)' ))
 
 $(eval $(call TestHostCommand,working-gcc, \
@@ -47,8 +48,8 @@ $(eval $(call TestHostCommand,working-gcc, \
 
 $(eval $(call SetupHostCommand,g++, \
        Please install the GNU C++ Compiler (g++) 4.8 or later, \
-       $(CXX) -dumpversion | grep -E '^(4\.[8-9]|[5-9]\.?)', \
-       g++ -dumpversion | grep -E '^(4\.[8-9]|[5-9]\.?)', \
+       $(CXX) -dumpversion | grep -E '^(4\.[8-9]|[5-9]\.?|10\.?)', \
+       g++ -dumpversion | grep -E '^(4\.[8-9]|[5-9]\.?|10\.?)', \
        g++48 --version | grep g++, \
        g++49 --version | grep g++, \
        g++5 --version | grep g++, \
@@ -56,6 +57,7 @@ $(eval $(call SetupHostCommand,g++, \
        g++7 --version | grep g++, \
        g++8 --version | grep g++, \
        g++9 --version | grep g++, \
+       g++10 --version | grep g++, \
        g++ --version | grep -E 'Apple.(LLVM|clang)' ))
 
 $(eval $(call TestHostCommand,working-g++, \
@@ -141,10 +143,12 @@ $(eval $(call SetupHostCommand,wget,Please install GNU 'wget', \
 $(eval $(call SetupHostCommand,perl,Please install Perl 5.x, \
        perl --version | grep "perl.*v5"))
 
+$(eval $(call CleanupPython3))
+
 $(eval $(call SetupHostCommand,python,Please install Python 2.x, \
-       python2.7 -V 2>&1 | grep Python, \
-       python2 -V 2>&1 | grep Python, \
-       python -V 2>&1 | grep Python))
+       python2.7 -V 2>&1 | grep 'Python 2.7', \
+       python2 -V 2>&1 | grep 'Python 2', \
+       python -V 2>&1 | grep 'Python 2'))
 
 $(eval $(call SetupHostCommand,git,Please install Git (git-core) >= 1.7.12.2, \
        git --exec-path | xargs -I % -- grep -q -- --recursive %/git-submodule))