include: fix prereq tests for perl and file (#18911)
[openwrt/staging/yousong.git] / include / prereq-build.mk
index 7945f053251b3ce5f5c76e1c3faadd245ff0e711..926a06f8ba4130f5dcafc6bc0166368bff04dc6c 100644 (file)
@@ -132,7 +132,7 @@ $(eval $(call SetupHostCommand,wget,Please install GNU 'wget', \
        wget --version | grep GNU))
 
 $(eval $(call SetupHostCommand,perl,Please install Perl 5.x, \
-       perl --version | grep "perl 5"))
+       perl --version | grep "perl.*v5"))
 
 $(eval $(call SetupHostCommand,python,Please install Python 2.x, \
        python2.7 -V 2>&1 | grep Python, \
@@ -146,7 +146,7 @@ $(eval $(call SetupHostCommand,git,Please install Git (git-core) >= 1.6.5, \
        git clone 2>&1 | grep -- --recursive))
 
 $(eval $(call SetupHostCommand,file,Please install the 'file' package, \
-       file --version | grep file))
+       file --version 2>&1 | grep file))
 
 $(eval $(call SetupHostCommand,openssl,Please install the 'openssl' utility, \
        openssl version | grep OpenSSL))