build: fix `which` detection on Fedora & MacOS
[openwrt/staging/thess.git] / include / prereq-build.mk
index 9242407b1896321b376701a8f8928157c95cfcd0..e1993444f7855695c95ce86d9d8a23825b340d97 100644 (file)
@@ -186,7 +186,9 @@ $(eval $(call SetupHostCommand,rsync,Please install 'rsync', \
        rsync --version </dev/null))
 
 $(eval $(call SetupHostCommand,which,Please install 'which', \
-       which which | grep which))
+       /usr/bin/which which, \
+       /bin/which which, \
+       which which))
 
 $(STAGING_DIR_HOST)/bin/mkhash: $(SCRIPT_DIR)/mkhash.c
        mkdir -p $(dir $@)